PHP scan函数远程拒绝服务漏洞(CVE-2013-6712)

  • A+
所属分类:linux安全
摘要

PHP 5.5.6之前版本ext/date/lib/parse_iso_intervals.c内的scan函数没有正确限制创建DateInterval对象,可使远程攻击者通过特制的

发布日期:2013-11-27
更新日期:2013-12-03

受影响系统:
PHP PHP <= 5.5.6
描述:
--------------------------------------------------------------------------------
BUGTRAQ  ID: 64018
CVE(CAN) ID: CVE-2013-6712

PHP是一种HTML内嵌式的语言。

PHP 5.5.6之前版本ext/date/lib/parse_iso_intervals.c内的scan函数没有正确限制创建DateInterval对象,可使远程攻击者通过特制的间隔规范,利用此漏洞可造成拒绝服务(堆溢出)。

<*来源:Oden Eriksson
  *>

建议:
--------------------------------------------------------------------------------
厂商补丁:

Google Nexus Class 0 'Flash' SMS远程拒绝服务漏洞

Google Nexus系列手机在处理大量特制SMS消息后会重启或无法连接到移动设备互联网服务,攻击者可利用此漏洞造成拒绝服务。

PHP
---
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://www.php.net/downloads.php
http://git.php.net/?p=php-src.git;a=commit;h=12fe4e90be7bfa2a763197079f68f5568a14e071

推荐阅读:

生产环境实用之LNMP架构的编译安装+SSL加密实现 http:///Linux/2013-05/85099.htm

LNMP 全功能编译安装 for CentOS 6.3笔记 http:///Linux/2013-05/83788.htm

CentOS 6.3 安装LNMP (PHP 5.4,MyySQL5.6) http:///Linux/2013-04/82069.htm

除非注明,否则均为@蒲公英网原创文章,转载必须以链接形式标明本文链接

本文链接:https://www.aipgy.com/25638.html

avatar

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: